Forums : SG20 FTP Server

Note: OldMan can be sporadic in his visits. If you do not get an answer fast enough, just contact him.

It is currently Mon Oct 23, 2017 9:20 am All times are UTC -4 hours

SG20 FTP Server

satgate

S
Sun Feb 20, 2005 3:12 pm
Quote
Hello,
I would like to set up a FTP Server on the Magnia SG20 with only private access, disable anonymous access, and set quota hard disk on the 2nd Hard disk of the SG20,
Could somebody help me?
I'm new in the Linux world.
So... step by step.
thanks
Erich

AnOldMan

A
Wed Feb 23, 2005 6:30 pm
Quote
First follow the steps for: Adding FULL FTP Access
/magnia/webmin_installation
This will give you access to the machine locally as root.
Next follow the steps for: WebMin Installation
/magnia/adding_full_ftp_access
This will give you the ability to work on the system from a graphical interface.
You can then mess with the WU FTP settings by going to:
http://192.168.1.1:10000/wuftpd/
You will also have to access the Toshiba Admin pages and open your firewall for FTP.
http://192.168.1.1:8282/
And click on "Firewall" then "Customize" then check off "FTP" and apply.
Keep in mind that this opens up your Magnia to malicious attacks from the internet.

DrSterni

D
Sun Apr 24, 2005 5:05 am
Quote
Hi OldMan and the others!
There's a question left for me, as I just want to have the full FTP-Access to my machine and since I was trying to change the WuFTP-Settings I got no access at all any more
You say:
anoldman wrote:
First follow the steps for: Adding FULL FTP Access
/magnia/webmin_installation
This will give you access to the machine locally as root.

Well... no, it won't
In that particular post you just mention that one can play around with the Server-Settings. Ok... So I did (just with the users and user-groups).
The problem: I did not like my settings. So I changed everything back to the values there were before.
Now all the access-rights seem to be gone. I alway get "Login incorrect" after logging in (with the standard-passwords!)
Any ideas?
Greetings, Sterni.
Rhythm is life and life is rhythm...

DrSterni

D
Sun Apr 24, 2005 5:59 pm
Quote
Please forget it...
Was a really lame mistake I was doing... Everything's running fine again...
Rhythm is life and life is rhythm...

AnOldMan

A
Thu Apr 28, 2005 9:52 pm
Quote
I have found that after you make the modifications I recommended you can then login using username "root" and password would be your default Toshiba system password.
You could probably enable user access, but I haven't really tried - simply because I leave my firewall on and only access the unit from the LAN.
You can also access the unit remotely using PPTP VPN access. I set up a user account with a long strange username and password, and made the PPTP VPN server allow this account VPN access. (Higher Security)