GNOME RPM Installation Order

If you want your VNCserver to serve up more than a text window, you need to install a GUI. After much trial-and-error, here's the install order I ended up with:GNOME 2.2.0 Installation Order for a Magnia SG20
libxml libxml2 2.4.19-4 already installed
libxml-1.8.17-3.i386.rpm
libxslt libxslt-1.0.15-1.i386.rpm
glib glib 1.2.10-5 already installed
linc linc-1.0.1-1.i386.rpm
libIDL libIDL-0.8.0-3.i386.rpm
ORBit2 ORBit-0.5.13-3.i386.rpm
intltool intltool-0.17-1.i386.rpm
pango pango-1.0.1-1.i386.rpm
atk atk-1.0.1-1.i386.rpm
gtk gtk 1.2.10-15 already installed
gconf oaf-0.6.8-3.i386.rpm
GConf-1.0.9-4.i386.rpm
gnome-mime-data gnome-mime-data-1.0.4-1.noarch.rpm
gnome-vfs gnome-vfs-1.0.5-4.i386.rpm
audiofile audiofile-0.2.3-1.i386.rpm Probably not needed
esound esound-0.2.24-1.i386.rpm Probably not needed
gtk-engines libungif-4.1.0-10.i386.rpm
imlib-1.9.13-3.7.x.i386.rpm
gtk-engines-0.11-10.i386.rpm
libgtop libgtop-1.0.12-8.i386.rpm
libgail-gno me
gnome-applets gnome-libs-1.4.1.2.90-14.i386.rpm
libghttp-1.0.9-2.i386.rpm
gdk-pixbuf-gnome-0.14.0-8.i386.rpm
pygtk-0.6.9-3.i386.rpm
pygnome-1.4.2-3.i386.rpm
libglade-0.17-5.i386.rpm
pygtk-libglade-0.6.9-3.i386.rpm
libgnomeprint15-0.35-4.i386.rpm
xloadimage-4.1-21.i386.rpm
umb-scheme-3.2-21.i386.rpm
guile-1.3.4-19.i386.rpm
librep-0.15.1-3.i386.rpm
rep-gtk-0.15-7.i386.rpm
rep-gtk-gnome-0.15-7.i386.rpm
fortune-mod-1.0-20.i386.rpm
xscreensaver-3.33-4.i386.rpm
aumix-2.7-8.i386.rpm
control-center-1.4.0.1-31.i386.rpm
pygnome-libglade-1.4.2-3.i386.rpm
sawfish-1.0.1-9.i386.rpm
gnome-core-1.4.0.4-54.i386.rpm
gnome-applets-1.4.0.5-6.i386.rpm
gnome-utils gnome-utils-1.4.0-9.i386.rpm
gnome-games gnome-games-1.4.0.1-5.i386.rpm
librsvg librsvg-1.0.2-1.i386.rpm
gdm2 sgml-common-0.6.3-9.noarch.rpm
xml-common-0.6.3-9.noarch.rpm
docbook-dtds-1.0-8.noarch.rpm
openjade-1.3.1-4.i386.rpm
scrollkeeper-0.3.4-5.i386.rpm
xsri-2.0.3-1.i386.rpm
switchdesk-3.9.8-2.i386.rpm
xinitrc-3.22-1.noarch.rpm
libuser-0.50.2-1.i386.rpm
usermode-1.53-2.i386.rpm
gdm-2.2.3.1-23.i386.rpm
eel eel-1.0.2-11.i386.rpm
bug-buddy bug-buddy-2.0.6-9.i386.rpm
gtk-doc perl-SGMLSpm-1.03ii-4.noarch.rpm
docbook-style-dsssl-1.76-1.noarch.rpm
docbook-utils-0.6.9-25.noarch.rpm
gtk-doc-0.5.9-1.noarch.rpm
fnlib-0.5-9.i386.rpm


installing package enlightenment-0.16.5-1 needs 8Mb on the / filesystem
oh well, guess I don''t need enlightenment!
EDIT /root/.vnc/xstartup TO LOOK LIKE THIS:
#!/bin/sh
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
exec gnome-session

YES, IT ACTUALLY WORKS...
I am going to try KDE next, I didn''t like gnome very much :P

Top